July 13, 2008

Shucks!

Today was probably the best flying day we’ve had all year. Blue sky, warm sunshine and hardly any wind. Unbelievable considering how windy it’s been for weeks now (no exaggeration).

Only trouble is, Rosie doesn’t fly Sundays. Shucks!

So I decided to nip down to the Our Trike workshop to check out the replacement CHT/RPM gauge. Grabbed the new jerry can I recently got on Ebay as I knew there wasn’t much fuel left in the tank and picked up 10 litres of unleaded and a litre of 2-stroke oil on the way (it needs a 40-1 petrol/oil mixture).

Pulled Our Trike out into the open, reattached the battery lead, checked everything over, topped up the tank and keyed the ignition. Shucks! It just would not start.

So I removed the plugs, which of course were totally oiled up, and cleaned them – 3 times eventually. I also checked the fuel filter and removed the fuel lines and carburettor plugs to make sure fuel was getting through. It was. Still would not start. What the heck could be the reason?

Aha, I thought. There’s an ignition master switch which I’d switched to ‘on’ – what if that’s making a poor connection? So I switched it off and on 3 or 4 times and then keyed the ignition again. Yippee! It started. Memo – think about replacing that dang switch!

Right – check the gauge……… oh no!! It’s not working!

I tried switching the connections as for a while the CH temperature needle seemed to be responding as the RPM needle should have been when I revved the engine. But no luck – couldn’t get it working. So now I’ve got to check the wiring and try to find out why not. I found what looked like some old wiring diagrams previously but it won’t be at all easy on a 20 year old microlight.

Shucks and shucks again! Not a particularly successful day 🙁